Jump to content

What happened to your ChampCar today? - 2020


Recommended Posts

  • Replies 812
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

So, we officially took two cars to a track day at Autobahn Full Course today....believe it or not, both cars had zero issues and drove back on the trailer...this is a first for us in 7 years of racing

Not very solid logic, but by spending a little bit of money on a new electric tongue jack and some paint for the race trailer  I was distracted away from spending lots of money on the race car.

☝️These guys: fun at parties. 

Posted Images

used the day off to unload the trailer and cars from Sebring, put the Cobra up on the rack and did the post race inspection.  Found a few issues with the car plus the new upgrades for Road Atlanta that need to be done.   Put all our new hardware into the case too :)

IMG_20191230_164729.jpg

  • Like 1
Link to post
Share on other sites
1 minute ago, MoparBoyy said:

used the day off to unload the trailer and cars from Sebring, put the Cobra up on the rack and did the post race inspection.  Found a few issues with the car plus the new upgrades for Road Atlanta that need to be done.   Put all our new hardware into the case too :)

IMG_20191230_164729.jpg

That's a heck of a display case.

Link to post
Share on other sites
Just now, enginerd said:

That's a heck of a display case.

 

got it at an estate auction for like $50.. its some fancy pants one that was like a $1200 new.

Link to post
Share on other sites

KD unit. Outstanding.

 

Question: looks like you have a Power Brake booster. Does this carb have a Vacuum outlet? My KD does not have a line for the brake booster.

 

44 minutes ago, TiredBirds said:

just a little 2bbl... 

eng1.jpg

eng2.jpg

 

Link to post
Share on other sites
19 hours ago, Team Infiniti said:

That blue is the wrong hue 🤔

how so? It is a Pontiac after all.... So it is Pontiac blue. Looks sharp!

Image preview

19 hours ago, Cam Benty said:

KD unit. Outstanding.

 

Question: looks like you have a Power Brake booster. Does this carb have a Vacuum outlet? My KD does not have a line for the brake booster.

 

 

Intake does, large port under the carb. 

Link to post
Share on other sites

The good: we've got a roller again.  Finished up the exhaust and fuel cell bulkhead.  Rewired and installed the new gauge pod.  Wired up and tested the redesigned fuel system, fixed a couple small leaks.  Filled and tested the new Hunsaker fuel jugs.  Installed new wheels.  The bad: couldn't get it to fire.  We didn't change anything on the engine since it ran last so I'm guessing wiring.  Probably pulled something loose somewhere so I've got some searching to do this week.  Unfortunately I ran the battery down too low and I had to quit for the night.

Link to post
Share on other sites

Pulled and disassembled my new used engine and found bad connecting rod and bearing.  Looks like a new crank and at least one rod.  

51C393D1-6FD1-4F28-B090-899BDFDD3A2B.jpeg

Edited by TimS
Added pick
  • Sad 1
Link to post
Share on other sites
14 hours ago, TimS said:

Pulled and disassembled my new used engine and found bad connecting rod and bearing.  Looks like a new crank and at least one rod.  

51C393D1-6FD1-4F28-B090-899BDFDD3A2B.jpeg

ahh just get a Scotch Bright green pad and hit it, should be fine. 

Link to post
Share on other sites

Found and fixed the missing/hidden ground connection. Car cranked right up.  Did a little more wiring cleanup and rearranging.  On a side note, the little Battery Tender LiFePo battery I bought doesn't have much in the way of ah, but their low volt reset feature works.  Happy I don't need another battery after running it down too low during electrical testing.

 

Grabbed the cherry picker and did a little redneck body work on the front end to get the hood/bumper/headlight buckets better aligned.  Now I can install the new aero catches and finish the radiator vent on the new hood.  Also mocked up the frostfighter defrost grid on the new lexan windshield.  Glad I didn't start the install after reading Huggies post on the subject.

 

Only a few little things to tidy up before the running car becomes a running/driving/track ready car again (only been 3 1/2 years 😮).  Hoping I can terrorize some of the local back roads with it this coming weekend.  Initial shakedown track day at CMP tentatively (weather dependent) scheduled for 2/1.

 

 

  • Like 4
Link to post
Share on other sites
5 minutes ago, TiredBirds said:

Looks like you got a hold of our fab guy... just be careful when you walk around the carbird.thumb.JPG.1a7dbf8c713d9b9eb2dd9c6771b1df1e.JPG

 

Well, the plan is to trim it down to a reasonable shape... Not that yours is unreasonable.

 

On a side note: Why does my home depot not carry 1/2" birch plywood.  I am using 3/4 and its a bit too much in my opinion.  

Link to post
Share on other sites
39 minutes ago, Team Infiniti said:

Turbo or non?

 

Wouldn't another engine be best?

Bmw M20. This is second “good used engine from a good friend of mine “. I’m done with the used junk. No turbo 

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...