Jump to content

Water temp gauge


enginerd
 Share

Recommended Posts

I installed an aftermarket water temp gauge and sending unit last night. Haven’t tested it yet. 
 

I have a theoretical concern that it won’t read the water temp well for a couple reasons:

1) the sending unit is quite short and is recessed within the NPT adapter fitting thing. It’s definitely not sticking out into the flow.
2) It is also mounted in such a way that the adapter will trap air and an air bubble can/will form at the sending unit.

 

Will this result in inaccurate water temp readings? Readings that lag behind actual water temp?

Edited by enginerd
Link to comment
Share on other sites

29 minutes ago, Team Infiniti said:

Recessed should still read, can you flip it over to get rid of air pocket?

I would have to find a different location. It’s installed in a housing of sorts out of convenience. Would need to do some cutting and welding to make a new spot for the sensor. 

Link to comment
Share on other sites

  • Technical Advisory Committee

M20 thermostat housing is notorious for being the highest point- and any leaks causes air to get onto the sensor giving you a false LOW reading.

 

You can put a gauge in the back of the block at the outlet where coolant used to go to the throttle body.  There is also the return for that coolant into the bottom of the throttle body, which can be tapped.  This will give a reading around 160f when the engine is operating normally (80c = 176f)

 

The best place to put it is honestly the lower radiator hose, because that will give you the highest temp. Not really long enough to put a temp sensor insert though.  

 

My temp sensor is still in the thermostat, with an adapter.  it works fine. 

A pressure sensor is right next to it, to alert if there is any potential air trapped up there.

 

 

Link to comment
Share on other sites

43 minutes ago, E. Tyler Pedersen said:

Just put a piece of tube from your overflow to your windshield.  You'll know when you're overheating quickly :) 

 

Actually did that once with the crank case breather, though it was looped back to the catch can.  Had to put new rings in that car before the next event.

Link to comment
Share on other sites

  • Administrators
2 hours ago, Grufton said:

 

Actually did that once with the crank case breather, though it was looped back to the catch can.  Had to put new rings in that car before the next event.

 

I actually have this setup on my car with the overflow in case my drivers dont want to pay attention to the gauges. 

Link to comment
Share on other sites

16 hours ago, enginerd said:

I would have to find a different location. It’s installed in a housing of sorts out of convenience. Would need to do some cutting and welding to make a new spot for the sensor. 

 

off the cuff idea - while the engine is running, unscrew the sensor to "bleed" off whatever may be inhibiting water from getting to the sensor?

Link to comment
Share on other sites

Thanks for all the input. I went ahead with the easy install and it gave an encouraging sign that it’s reading block water temp (fired up engine and within a minute the needle was climbing over 100). I will have to test it this weekend with some easy running and see if it levels out near the tstat opening temp. And then also do some kind of testing to see it’s response speed.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...