Jump to content

What happened to your ChampCar today 2021 ??


 Share

Recommended Posts

17 hours ago, Timothy G. Elliott said:

Well it's out of trailer quarantine and into the garage, haven't found out for sure why it is so lame, but put the new distributor and coil back on it, still does lose power when warm, change the plugs, and checked the cylinder's, also cleaned the lift pump fuel filter nothing out of the ordinary. Wondering if the 044 fuel pump is not making enough pressure. That is what it acts like... Well enough for this weekend. I do have to fix the axel shaft hubs leaking a bit of gear lube on both sides. Might rebuild my first trans axel first and install that again I think the reverse switch was the leak on that one... To much work, but always fun when it's on the race car.

I had a mostly clogged fuel filter which acted a lot like how you describe. 

  • Like 1
Link to comment
Share on other sites

2 hours ago, mhr650 said:

 

That would cause me to be very suspicious of the wiring/relay. Also check your surge tank closely, they are infamous for coming full of chips, I know this one from experience.

 

What makes it difficult for you is that it only happens when everything is hot, it is very difficult to recreate this in testing around the neighborhood. Good luck.

Thats my plan check fuel pump wiring maybe take it a step further and set up a switch for the main and go direct to it, right now it's fed off the oem relay which also is new!

Link to comment
Share on other sites

31 minutes ago, Timothy G. Elliott said:

Thats my plan check fuel pump wiring maybe take it a step further and set up a switch for the main and go direct to it, right now it's fed off the oem relay which also is new!

I have my fuel pump wiring set up like that. I can easily swap the spade connectors (~10 seconds) to go direct from switch to pump or to bring the relay into the circuit. Direct is great for garage work / pumping out the tank / troubleshooting. I run it through the relay before going to the track though, for safety. 

Edited by enginerd
  • Like 1
Link to comment
Share on other sites

  • Administrators
38 minutes ago, mcoppola said:

 Did you cut those uprights by hand?

nice job!

 

My first time cutting thick aluminum with my plasma cutter. it looks like shit. but it works. 

Link to comment
Share on other sites

On 4/26/2021 at 12:52 AM, Team Infiniti said:

Trans fluid after last race

 

51127444267_9358f72c25_b.jpg

 

Tear down

 

51139882154_f06e2088f3_b.jpg

 

3rd gear clutch pack showing heat

 

51140211200_66e3ae5311_b.jpg

 

and wear

 

51138431347_d0bc4547df_b.jpg

 

3rd damaged drum, close to ripping circle clip out.

 

51138431352_9bec5a14af_b.jpg

 

Parts unit pulled off engine & stripped

 

51140211355_8a1303a7b5_b.jpg

 

"New" drums, pistons & planets to be cleaned inspected

 

51139324923_75746f73c1_b.jpg

 

Monday:

Order clutches, gaskets & 2/4 band.

 

Thank you bill for fixing the link issue, new clutches have arrived but here are the photos that didnt work earlier

  • Like 2
Link to comment
Share on other sites

21 minutes ago, Team Infiniti said:

Thank you bill for fixing the link issue, new clutches have arrived but here are the photos that didnt work earlier

That fluid looks a little dark... Probably smells nice too.

 

Looks like third took some abuse in those fast late laps. 😀

  • Like 2
Link to comment
Share on other sites

1 hour ago, Team Infiniti said:

Worth it, 4th band and 3rd clutch pack just arrived in the mail, $149!

 

Anyone that needs HD auto rebuild kits, see Level 10 transmission.

HD....  hmmm...  sounds like points!  #greenfont.

  • Haha 3
Link to comment
Share on other sites

Our new junk yard motor will be getting new rings, rod bearing and a valve job so we can get another good run of racing. Should be back together and in the car in a week or so and ready for some testing. Easy work, got to love it!

IMG_1912.jpg

Edited by 55mini
wording
  • Like 1
Link to comment
Share on other sites

Met with a highly recommended shop, and checked out some of their cage work and other cars they are building. Going to bring them the car Thursday, full TIG job. I keep saying it needs to be done right, so... It is going to get done right. 

 

On the mechanical side, a bunch more parts coming. Decided since I am doing engine/tranny mounts, clutch, etc... I might as well just pull out the engine and replace other common leaks and maintenance items once the cage is out. 

Edited by Fetterhund
  • Like 3
Link to comment
Share on other sites

20 minutes ago, Fetterhund said:

Met with a highly recommended shop, and checked out some of their cage work and other cars they are building. Going to bring them the car Thursday, full TIG job. I keep saying it needs to be done right, so... It is going to get done right. 

 

On the mechanical side, a bunch more parts coming. Decided since I am doing engine/tranny mounts, clutch, etc... I might as well just pull out the engine and replace other common leaks and maintenance items once the cage is out. 

TIG is overkill, but at least you should be getting a good cage after the previous fiascos. Good luck.

 

*Nascar cages are mig.

  • Like 2
  • Confused 1
Link to comment
Share on other sites

Think I just discovered the problem I checked fuel pressure and all was well, amp draw was ok too, just checked voltage at the fuel pump and is only 11.4 volts! Battery is at 13.9, going to rewire the pumps and remove the relay from the equation and see what I get.

  • Like 3
Link to comment
Share on other sites

On 5/6/2021 at 8:21 AM, Bill Strong said:

testing my awesomeness. Ed, I can post images if I upload them.

 

Upload

opel-wing.jpg

Here's how I tested my wing struts:

KIMG1891.jpg.03681cec86048f11018b939f712d80d1.jpg

I think yours would hold up the complete engine.

 

Which leads me to believe that you're planning on making about 700 lbs of downforce. So what engine are you really going to be using, Bill? ;)

  • Haha 1
Link to comment
Share on other sites

18 hours ago, Timothy G. Elliott said:

Think I just discovered the problem I checked fuel pressure and all was well, amp draw was ok too, just checked voltage at the fuel pump and is only 11.4 volts! Battery is at 13.9, going to rewire the pumps and remove the relay from the equation and see what I get.

Bigger wire and check voltage drop across the relay contacts, likely to much draw for wire size/length or low voltage to the relay contacts to begin with.  Be sure to check ground as well.

  • Like 1
Link to comment
Share on other sites

1 hour ago, TimS said:

Bigger wire and check voltage drop across the relay contacts, likely to much draw for wire size/length or low voltage to the relay contacts to begin with.  Be sure to check ground as well.

My thoughts exactly!

Link to comment
Share on other sites

On 5/6/2021 at 2:41 PM, Team Infiniti said:

Worth it, 4th band and 3rd clutch pack just arrived in the mail, $149!

 

Anyone that needs HD auto rebuild kits, see Level 10 transmission.

How much time was on that trans?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...